Firmware 641 for PowerPod is available

Post Reply
Velocomp
Velocomp CEO
Posts: 6141
Joined: Fri Jan 11, 2008 8:43 am

Firmware 641 for PowerPod is available

Post by Velocomp » Thu Jul 26, 2018 1:22 pm

This firmware corrects bugs found in firmware 640.

* Whenever a sensor scan is performed (even to the same sensors) PowerPod is forced into a new, O&B calibration ride.
* Fixed a bug causing Isaac error message to appear when using the Device/Reset Profile command.

To obtain this firmware, connect your PowerPod to Isaac, then go to "Device/Check online for firmware update".

Make sure you do not touch your PowerPod or your computer during the firmware update.
John Hamann

Speedyg
Posts: 17
Joined: Thu Nov 30, 2017 4:35 am

Re: Firmware 641 for PowerPod is available

Post by Speedyg » Mon Aug 06, 2018 10:32 am

When PP is moved from one bike to another, which it has previously been paired with, does it default to a new scan for sensors and force an O&B cal, or does it just recognize the previously st up bike and go to that profile and we’re good to go?

Velocomp
Velocomp CEO
Posts: 6141
Joined: Fri Jan 11, 2008 8:43 am

Re: Firmware 641 for PowerPod is available

Post by Velocomp » Mon Aug 06, 2018 10:34 am

Speedyg wrote:
Mon Aug 06, 2018 10:32 am
When PP is moved from one bike to another, which it has previously been paired with, does it default to a new scan for sensors and force an O&B cal, or does it just recognize the previously st up bike and go to that profile and we’re good to go?
It recognizes the sensors from the previous bike, and you're good to go.

Sensor scan is ALWAYS started by an action of the user.
John Hamann

Dusan Turkulov
Posts: 9
Joined: Sat Mar 30, 2019 5:05 pm

Re: Firmware 641 for PowerPod is available

Post by Dusan Turkulov » Sun Mar 31, 2019 9:21 am

iBike_03_31_2019_1447_3_km.ibr
Please check this file, and tell me is it correct. This is calibration O&B file and after that mr ride to home. Bike is road, aero, 700x25,
(29.7 KiB) Downloaded 20 times
Please check this file, and tell me is it correct. This is calibration O&B file and after that mr ride to home. Bike is road, aero, 700x25,

Kcblair
Posts: 25
Joined: Tue Apr 02, 2019 4:21 pm

Re: Firmware 641 for PowerPod is available

Post by Kcblair » Sun May 19, 2019 5:42 pm

Hello guys, got no response in general discussion, so I'll try here. I upgraded to firmware 641, and the O&B calibration doesn't work. The PP goes into the 1-100 continuous ride. Is this now the standard calibration ride ?

Thanks, ken

Velocomp
Velocomp CEO
Posts: 6141
Joined: Fri Jan 11, 2008 8:43 am

Re: Firmware 641 for PowerPod is available

Post by Velocomp » Sun May 19, 2019 7:07 pm

Please post a .ibr ride file
John Hamann

Kcblair
Posts: 25
Joined: Tue Apr 02, 2019 4:21 pm

Re: Firmware 641 for PowerPod is available

Post by Kcblair » Sun May 19, 2019 7:47 pm

OK, where do I find that file ? Thank You.

Kcblair
Posts: 25
Joined: Tue Apr 02, 2019 4:21 pm

Re: Firmware 641 for PowerPod is available

Post by Kcblair » Sun May 19, 2019 8:43 pm

Thank you John, while I wait, to find where to get this file, please let me clarify. When I perform a profile update, the PP Lite, does a or, requests a calibration ride, no problem. But, since the firmware update from 640 to 641, the PP lite, no longer does the new O&B ride. It does the older 1-100 calibration ride, then starts producing power watts. And all goes well. Ken

Kcblair
Posts: 25
Joined: Tue Apr 02, 2019 4:21 pm

Re: Firmware 641 for PowerPod is available

Post by Kcblair » Mon May 20, 2019 8:54 am

I think I figured it out. Here is attached ride file.
iBike_05_19_2019_1338_13_Miles.ibr
(32.82 KiB) Downloaded 17 times
Also, I just discovered, I can't perform a calibration check In Isaac, , because the file is not a O&B ride, says the message. Ken

Kcblair
Posts: 25
Joined: Tue Apr 02, 2019 4:21 pm

Re: Firmware 641 for PowerPod is available

Post by Kcblair » Mon May 20, 2019 12:58 pm

Hello John. Did a little testing today and here is whats happening with the calibration mode.

I double checked the instructions for an O&B cal. Push button 4 sec. wake up sensors, green blinks and turns solid, great. Push again , turns orange and then shortly later, red/green. I ride to my starting point, stop, still blinks red/green. I push the button once, flashes orange, off I go. But, at 50, no red light, Still blinks orange, and keep peddling till 100, light turns to green, and power numbers start appearing on head unit. Wish I could return to FW 640, if we can't solve this, I guess it's only an annoyance .Ken

Velocomp
Velocomp CEO
Posts: 6141
Joined: Fri Jan 11, 2008 8:43 am

Re: Firmware 641 for PowerPod is available

Post by Velocomp » Mon May 20, 2019 5:25 pm

Are you climbing a hill on the out portion? If you are going slow then Pp will think you have turned around. Please post a ride file.
John Hamann

Kcblair
Posts: 25
Joined: Tue Apr 02, 2019 4:21 pm

Re: Firmware 641 for PowerPod is available

Post by Kcblair » Mon May 20, 2019 7:05 pm

Thanks John,

No , not climbing hill, doing the calibration ride on my straight , flat street. But, after screwing around ith different profiles, and doing several calibration rides, the last test worked. I finally saw the red light come on at 50, I stopped, and returned. When for a ride, but when I down loaded the ride and tweaked the new profile, I noticed the cadence sensor was shown as connected. I've tried several times to pair the cad. sensor, but no luck .

Will grab the ride file shortly. Bike is plugged into another PC.
iBike_05_19_2019_1338_13_Miles.ibr
(32.94 KiB) Downloaded 9 times
Update: Well, I figured out how to perform a hard reset, now the Cad & Speed sensor are paired and showing in the profile. Apparently, I must have done a hard reset, at some point, to get the O&B ride calibration to work. Now that I have done a hard reset, it's telling me to do a re-cal ride, which I expected. Bike is in for the night.

Now, I have ordered a second speed sensor, for a second bike, when it gets here, time to set up my climbing bike. Saw the video, on how to do that, but I'm using the PP Lite, and you have addressed how to perform that function.

My plan, after I get all this working, is to get more speed sensors, and buy the upgrade the PP Lite, and make life really simple for myself.

Thank you so much, John , you have been very helpful, to this 72 yr. old cyclist. Ken
Attachments
iBike_10_08_2018_0010_1_Miles_CalRide.ibr
(15.63 KiB) Downloaded 13 times
Last edited by Kcblair on Mon May 20, 2019 8:28 pm, edited 1 time in total.

Kcblair
Posts: 25
Joined: Tue Apr 02, 2019 4:21 pm

Re: Firmware 641 for PowerPod is available

Post by Kcblair » Mon May 20, 2019 7:19 pm

I'm amazed, at how bikes have progressed , since I started riding 50+ yrs. ago. Started with 5 speed, friction shifting, clip peddles. Now , at age 72, I'm riding CF frame, thru-axles, disc brakes, and more sensors than most cars "LOL". My son noticed my bike, plugged into my PC (PowerPod) and wanted to know what that was all about. Ken

Velocomp
Velocomp CEO
Posts: 6141
Joined: Fri Jan 11, 2008 8:43 am

Re: Firmware 641 for PowerPod is available

Post by Velocomp » Tue May 21, 2019 1:24 pm

Kcblair wrote:
Mon May 20, 2019 7:19 pm
I'm amazed, at how bikes have progressed , since I started riding 50+ yrs. ago. Started with 5 speed, friction shifting, clip peddles. Now , at age 72, I'm riding CF frame, thru-axles, disc brakes, and more sensors than most cars "LOL". My son noticed my bike, plugged into my PC (PowerPod) and wanted to know what that was all about. Ken
:-)
John Hamann

Post Reply