Disable PowerPod BLE speed/cadence relay?

Post Reply
MaxVelo
Posts: 6
Joined: Thu Jun 27, 2019 3:04 pm

Disable PowerPod BLE speed/cadence relay?

Post by MaxVelo » Thu Jun 27, 2019 5:16 pm

Hello everyone,

I’m having issues with PowerPod BLE and my Polar v650
PowerPod works just fine, unfortunately the connection to my v650 doesn’t

I don’t get Power transfered to the Polar unit if I pair speed and cadence sensors to PowerPod as well as the head unit. (I’m using the Wahoo sensors.)

If I pair the sensors only to PowerPod I get Power/Speed/Cadence on my Polar, but unfortunately the distance calculated is not correct! On a 50km route I get approx double the distance so Polar will record 100km, also the average Speed is wrong then.

So I’m suspecting the v650 is not really compatible picking up speed accurately from PowerPod’s BLE stream

Anyone had such an experience before?

Is it possible to turn off relaying speed and cadence within power pod?

Then I could just pair speed&cadence sensors to the v650 and have power stream from PowerPod, just like it’s in “Ant+ mode” if I understand that correctly?

Velocomp
Velocomp CEO
Posts: 6079
Joined: Fri Jan 11, 2008 8:43 am

Re: Disable PowerPod BLE speed/cadence relay?

Post by Velocomp » Thu Jun 27, 2019 8:33 pm

Are you seeing incorrect information on your Polar device, or in the Isaac file?
John Hamann

MaxVelo
Posts: 6
Joined: Thu Jun 27, 2019 3:04 pm

Re: Disable PowerPod BLE speed/cadence relay?

Post by MaxVelo » Fri Jun 28, 2019 2:11 am

PowerPod records speed/distance and everything correctly, no problems there. Isaac file looks great.
It’s only the wrong distance that Polar records when connected to PowerPod that’s bothering me

(I’m using a polar Vantage V watch for running/swimming
I like the training load/recovery data it gives me
It also takes into account the training with the v650
So I get a pretty nice overview of my total training loads
otherwise I wouldn’t care a lot if the head unit was just for route/data display)

mir
Posts: 19
Joined: Fri Jul 26, 2019 5:43 am

Re: Disable PowerPod BLE speed/cadence relay?

Post by mir » Sat Jul 27, 2019 3:59 pm

I can confirm this too. But then I am able to pair the v650 directly to the sensors BLE stream and getting power data from the PP. This means the speed data is correct while getting power data as well. Since cadence works correct it must be the v650 which misreads the speed data from the BLE stream from the PP. The strange thing is that polar records max speed to be equal to average speed. Another strange thing is that if you upload the ride to polar flow the speed shown in the graphs are the correct speed data but the overview displays the wrong data. I tend to think this is a polar bug.

MaxVelo
Posts: 6
Joined: Thu Jun 27, 2019 3:04 pm

Re: Disable PowerPod BLE speed/cadence relay?

Post by MaxVelo » Thu Aug 01, 2019 4:53 pm

thanks for your contribution
good to see that I’m not the only one experiencing compatibility issues
Probably there aren’t a lot of polar users here

I haven’t given up on the combination yet
At least it’s working somehow and I get power from pp into the polar eco system
But the wrong distance is really annoying me

I will test again with different setups in my upcoming holiday
Would be interesting how a Garmin speed sensor works with polar and pp

mir
Posts: 19
Joined: Fri Jul 26, 2019 5:43 am

Re: Disable PowerPod BLE speed/cadence relay?

Post by mir » Thu Aug 01, 2019 7:18 pm

MaxVelo wrote:
Thu Aug 01, 2019 4:53 pm
I haven’t given up on the combination yet
At least it’s working somehow and I get power from pp into the polar eco system
But the wrong distance is really annoying me
If you use my setup your problem is solved.
MaxVelo wrote:
Thu Aug 01, 2019 4:53 pm
I will test again with different setups in my upcoming holiday
Would be interesting how a Garmin speed sensor works with polar and pp
This will not make any difference. The issue here is that the Polar is not able to currently interpret the speed data from the BLE stream supplied by the PP so whether you use a Garmin, Wahoo, or anything else the speed data will be interpreted wrongly. Personally I have tried Wahoo and anything else except for the Garmin ;-)

MaxVelo
Posts: 6
Joined: Thu Jun 27, 2019 3:04 pm

Re: Disable PowerPod BLE speed/cadence relay?

Post by MaxVelo » Fri Aug 02, 2019 2:06 pm

thanks, for my next ride I will definitely try to connect my wahoo sensors to polar and pp and turning on pp first before the v650

mir
Posts: 19
Joined: Fri Jul 26, 2019 5:43 am

Re: Disable PowerPod BLE speed/cadence relay?

Post by mir » Fri Aug 02, 2019 3:52 pm

MaxVelo wrote:
Fri Aug 02, 2019 2:06 pm
thanks, for my next ride I will definitely try to connect my wahoo sensors to polar and pp and turning on pp first before the v650
I you have previous paired cadence and speed through PP you need to unpair the PP from v650 before you will be able to pair the sensors to v650. When this is done you simply re-pair pp to v650 and then it will only fetch the power data from pp.

MaxVelo
Posts: 6
Joined: Thu Jun 27, 2019 3:04 pm

Re: Disable PowerPod BLE speed/cadence relay?

Post by MaxVelo » Sun Aug 04, 2019 2:40 pm

Thanks alot „mir“ for your tips!
I had a great ride this afternoon, turning on the v650 as last it was working perfectly!
Distance, Max Speed, Average Speed all correct, along with power data! Finally... :D

Post Reply