Powerpod unresponsive

Post Reply
Ian Boylan
Posts: 7
Joined: Wed Feb 22, 2017 6:45 am

Powerpod unresponsive

Post by Ian Boylan » Fri Sep 21, 2018 8:49 pm

As a result of injuries sustained in an collision I have not used my Powerpod for 18 months.
When I began to use it again last week it did not seem to hold its first charge but I put this down to the fact that the connection can be a little touchy and that it had not been securely connected.
It charged up perfectly the next time and after a ride charged for what seemed to me to be appropriate amount of time.
The next time I tried to use it it went steady red briefly and then flashing green. I tried to get a steady green out of it by cranking the wheel but could not. So I pressed the button again got no lights and set off.
At that time my garmin 520 said it was connected but gave me no power figures. No matter what I do since then it seems dead.
It will not respond to a button push even if I hold it long enough for a hard reset and I have tried on several occasions. It will not connect for a charge.
I would be grateful for any ideas on how to revive it
Warmest regards,
Ian Boylan

Velocomp
Velocomp CEO
Posts: 5240
Joined: Fri Jan 11, 2008 9:43 am

Re: Powerpod unresponsive

Post by Velocomp » Fri Sep 21, 2018 9:15 pm

Please email technicalsupport@velocomp.com for next steps.
John Hamann

Post Reply