PP no connection to Isaac

Post Reply
PaulK32
Posts: 20
Joined: Sat Mar 26, 2016 10:05 am

PP no connection to Isaac

Post by PaulK32 » Wed Oct 10, 2018 9:39 am

08-10-2018 I did a trainer ride with Profile 3 (Tacx) and Trainer ON.
10-10-2018 I did a mtb ride with Profile 4 (MTB) and Trainer OFF.

During the 10-10-2018 66km ride the power-data was displayed on the Garmin Edge 800. It is also in the .fit file of this ride on the Garmin. At home connected the PowerPod to my Win10 pc. It blinked red, but there came no connection to Isaac. I tried several times and there was no red blinking anymore on the PP.

I tried to start the PP, it gave 19 times green and 11 red. And that was it, after connecting to pc, no connection in Isaac.
I did a hard-reset, but during this 10 seconds, the green blinking started already after a one second. No connection in Isaac.

What can I do ?

PowerPod ANT/BLE with Powerstroke (FW6.41); I got this one 01-08-2018 as replacement after my PowerPod ANT had charging defect.

Velocomp
Velocomp CEO
Posts: 5243
Joined: Fri Jan 11, 2008 9:43 am

Re: PP no connection to Isaac

Post by Velocomp » Wed Oct 10, 2018 5:47 pm

Please email technicalsupport@velocomp.com for next steps.
John Hamann

Post Reply