PowerPod V1 won't calibrate, help please!

Post Reply
Manjimobx7
Posts: 2
Joined: Thu Jul 21, 2016 12:58 am

PowerPod V1 won't calibrate, help please!

Post by Manjimobx7 »

Hi,
I have a version 1 PowerPod that worked perfectly when I first bought it but after not using it for some time I had to send it back to Velocomp (nearly 2 years ago) to get the back up battery replaced. At the same time I bought a smart trainer and started doing most of my training indoors so haven't needed to use the PowerPod much but over those past 24 months have tried some dozen or so times to get the PowerPod unit up and running. I have tried both the "better" and "best" accuracy a number of times but haven't been able to get it working at all.
When trying to set it up for "better" accuracy I can get the unit to pair to the speed sensor and then to the Garmin after which it will then show to a solid yellow light as it is supposed to but it won't then flash yellow at all. The screen on the Garmin will show 0 watts most of the time but occasionally shows two dashes but never anything else.
I'm really frustrated with getting nowhere with this and hope somebody can point me in the right direction (please!).
Many thanks,
Andy.

Velocomp
Velocomp CEO
Posts: 6484
Joined: Fri Jan 11, 2008 8:43 am

Re: PowerPod V1 won't calibrate, help please!

Post by Velocomp »

Please email technicalsupport@velocomp.com for next steps. Tom will get you going!
John Hamann

Post Reply