Powerpod V3 not connecting to Garmin speed and Cadence Sensors

Post Reply
BVSCRIV
Posts: 9
Joined: Mon Sep 02, 2019 1:23 pm

Powerpod V3 not connecting to Garmin speed and Cadence Sensors

Post by BVSCRIV » Mon Sep 02, 2019 3:43 pm

Evening (happy Labour Day)!
I’m now the proud owner of a V3 and after setting up ISAAC on my Mac and sending profile 1 to the Powerpod, I’m now failing to connect it to both the Garmin cadence and speed sensors.

Both Sensors are awake (they are showing as connected to my Edge820).
I hold the Powerpod button until it flashes green however nothing connects (Powerpod flashes green for a quite a while and then switches off - neither Yellow for success or red for fail... just off). I’ve tried with the edge820 on (and connected to the sensors) as well as off (in case it makes a difference).

Any tips appreciated!

Velocomp
Velocomp CEO
Posts: 6251
Joined: Fri Jan 11, 2008 8:43 am

Re: Powerpod V3 not connecting to Garmin speed and Cadence Sensors

Post by Velocomp » Tue Sep 03, 2019 12:47 am

1) Confirm that your speed sensor is connected to your Garmin by spinning the wheel of your bike. You should see non-zero speed on your Garmin screen

2) Assuming 1) true, press-hold PP button for about 12 seconds, until its light goes out momentarily and then starts flashing. Release the button. This does a hard reset of PP

3) Press-hold PP button for about 4 seconds, until it starts flashing. Release button. This initiates the pairing process. Hopefully this will work!
John Hamann

BVSCRIV
Posts: 9
Joined: Mon Sep 02, 2019 1:23 pm

Re: Powerpod V3 not connecting to Garmin speed and Cadence Sensors

Post by BVSCRIV » Tue Sep 03, 2019 12:51 am

Thanks for the fast reply.
I’ll give it a go. If a hard reset is done though, should I do the Calibration ride before I re-attach it to ISAAC and reset the profile? Or after I have reset the profile?

Velocomp
Velocomp CEO
Posts: 6251
Joined: Fri Jan 11, 2008 8:43 am

Re: Powerpod V3 not connecting to Garmin speed and Cadence Sensors

Post by Velocomp » Tue Sep 03, 2019 12:57 am

If you already have your profile stored in your PP, there is no reason to reset it. Hard reset does not affect stored profiles.
John Hamann

BVSCRIV
Posts: 9
Joined: Mon Sep 02, 2019 1:23 pm

Re: Powerpod V3 not connecting to Garmin speed and Cadence Sensors

Post by BVSCRIV » Tue Sep 03, 2019 1:17 am

Brilliant. Thanks again. I’ll post back once I’ve tried it out and can confirm success (won’t be for a day or two though I’m afraid).

BVSCRIV
Posts: 9
Joined: Mon Sep 02, 2019 1:23 pm

Re: Powerpod V3 not connecting to Garmin speed and Cadence Sensors

Post by BVSCRIV » Wed Sep 04, 2019 12:44 pm

That’s done the trick! Just the calibration ride left now - can’t wait. Thanks again for the help and fast responses.

Post Reply