Calibration failed powerpod v3

Post Reply
bdetroyer
Posts: 1
Joined: Thu Jan 20, 2022 3:16 pm

Calibration failed powerpod v3

Post by bdetroyer »

I just bought a powerpod v3. Was very excited.

I updated firmware, setup the powerpod and did like 10 calibration rides.
Always same result. After the power went up to 100 I get blinking red light. This means the calibration ride failed.

So tried different bike with different wahoo sensors. Did a hard reset and started the process again. Same result.

This is frustrating.

In this forum los_leo had the same problem but there was no answer bto his problem
Velocomp
Velocomp CEO
Posts: 7525
Joined: Fri Jan 11, 2008 8:43 am

Re: Calibration failed powerpod v3

Post by Velocomp »

I see that you have already made many emails to technicalsupport@velocomp.com, and that Tom has responded to you promptly.

I'm not sure why you are additionally posting here.

You are welcome to post a ride file here but I highly doubt I can provide you more assistance, over and above what Tom has provided already.
John Hamann
Post Reply