PowerPod BLE and BLE speed/Cad sensor

Post Reply
Saleh8
Posts: 2
Joined: Sat Apr 13, 2019 7:07 am

PowerPod BLE and BLE speed/Cad sensor

Post by Saleh8 » Sat Apr 13, 2019 8:09 am

I am trying to pair Lezyne "Cadence/Speed flow sensor"(BLE only) with PowerPod BLE with no luck.

Is there something I have to do to make PP pair in BLE mode?

Velocomp
Velocomp CEO
Posts: 5747
Joined: Fri Jan 11, 2008 9:43 am

Re: PowerPod BLE and BLE speed/Cad sensor

Post by Velocomp » Sat Apr 13, 2019 11:37 am

BLE-only sensors won't work. Our instructions state that an ANT+ , or ANT/BLE speed sensor must be used.
John Hamann

Saleh8
Posts: 2
Joined: Sat Apr 13, 2019 7:07 am

Re: PowerPod BLE and BLE speed/Cad sensor

Post by Saleh8 » Sat Apr 13, 2019 4:06 pm

When you stated Ant/BLE that's mean Ant or BLE and thats why I got PowerPod with BLE function!! From its name it should be computable with BLE sensors.

I have wested money on PP BLE and now I have to buy a new Ant+ sensors!!

Velocomp
Velocomp CEO
Posts: 5747
Joined: Fri Jan 11, 2008 9:43 am

Re: PowerPod BLE and BLE speed/Cad sensor

Post by Velocomp » Sun Apr 14, 2019 7:44 am

I truly am sorry for your disappointment, but our product description very clearly says ANT or combination ANT/BLE sensors are required. We say this in bold letters on the product page:

"Requires USB charger, and ANT or ANT/BLE speed or speed/cadence sensor, not included."


The ANT/BLE version of PowerPod broadcasts its data in both formats.
John Hamann

Post Reply